aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-keyutils/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-keyutils/APKBUILD')
-rw-r--r--community/py3-keyutils/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/py3-keyutils/APKBUILD b/community/py3-keyutils/APKBUILD
new file mode 100644
index 00000000000..d4673297016
--- /dev/null
+++ b/community/py3-keyutils/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: Clayton Craft <clayton@craftyguy.net>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
+pkgname=py3-keyutils
+pkgver=0.6
+pkgrel=5
+pkgdesc="python bindings for keyutils"
+url="https://github.com/sassoftware/python-keyutils"
+arch="all"
+license="Apache-2.0"
+depends="python3 keyutils"
+makedepends="cython gettext keyutils-dev py3-setuptools python3-dev py3-pytest-runner"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/sassoftware/python-keyutils/archive/$pkgver.tar.gz"
+builddir="$srcdir/python-keyutils-$pkgver"
+
+# https://github.com/sassoftware/python-keyutils/issues/30
+options="!check"
+
+prepare() {
+ default_prepare
+
+ # fix python3 build by deleting stale .c file
+ rm keyutils/_keyutils.c
+}
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+e282d553a644d9b38c6256e027ee553a123bf21e4222491e22699ca5bc5041dedc4e9a9a8c1bafa44985f3b1d5fafd85ded9ed5332b6d94d6c62f3fa6bcb6d0d py3-keyutils-0.6.tar.gz
+"