aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-kiwisolver/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-kiwisolver/APKBUILD')
-rw-r--r--community/py3-kiwisolver/APKBUILD17
1 files changed, 10 insertions, 7 deletions
diff --git a/community/py3-kiwisolver/APKBUILD b/community/py3-kiwisolver/APKBUILD
index d6ef31d38b3..493a777ce7c 100644
--- a/community/py3-kiwisolver/APKBUILD
+++ b/community/py3-kiwisolver/APKBUILD
@@ -1,15 +1,16 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
pkgname=py3-kiwisolver
_pkgname=kiwisolver
-pkgver=1.2.0
+pkgver=1.4.5
pkgrel=0
pkgdesc="Efficient implementation of the Cassowary constraint solving algorithm"
url="https://github.com/nucleic/kiwi"
arch="all"
license="BSD-3-Clause-Attribution"
-depends="py3-setuptools"
-makedepends="python3-dev"
+depends="python3"
+makedepends="python3-dev py3-setuptools py3-cppy py3-setuptools_scm"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/nucleic/kiwi/archive/$pkgver.tar.gz"
builddir="$srcdir"/kiwi-$pkgver
@@ -17,16 +18,18 @@ replaces="py-kiwisolver" # Backwards compatibility
provides="py-kiwisolver=$pkgver-r$pkgrel" # Backwards compatibility
build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
python3 setup.py build
}
check() {
- PYTHONPATH="$(echo $PWD/build/lib.*-3*)" py.test-3
+ PYTHONPATH="$(echo build/lib.*-3*)" pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-
-sha512sums="05541ff46cc64b9958d714452138dc7bb343e6cc9308408a3f8cf25242e9640af37f8bfd22a7038e8ca70a895f57bdb983346259bce22b1630ac10b974d00a0e py3-kiwisolver-1.2.0.tar.gz"
+sha512sums="
+889e106c27915cb773bc13969605812c1ca01a139e992d2b3517eb20989ae41392bfdcdd63184a7777b13eff5109d167869087ea09149b1527e56a3455213b14 py3-kiwisolver-1.4.5.tar.gz
+"