aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-ldap3/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-ldap3/APKBUILD')
-rw-r--r--community/py3-ldap3/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/py3-ldap3/APKBUILD b/community/py3-ldap3/APKBUILD
index 527c2c57513..d9ff6b61f78 100644
--- a/community/py3-ldap3/APKBUILD
+++ b/community/py3-ldap3/APKBUILD
@@ -2,14 +2,15 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=py3-ldap3
_pkgname=ldap3
-pkgver=2.8
-pkgrel=1
+pkgver=2.9.1
+pkgrel=3
pkgdesc="A strictly RFC 4510 conforming LDAP V3 pure Python3 client"
url="https://github.com/cannatag/ldap3"
arch="noarch"
license="LGPL-3.0-or-later"
depends="python3 py3-asn1"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/cannatag/ldap3/archive/v$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
options="!check" # tests need running LDAP server
@@ -26,7 +27,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="5fd5d35910dbe9818f7c3dc4d3b89ff289a259728bee1bd42700ddc309d68123e41ed4e6ed8bf081138bb549f4d778c127ce50ac39f9cbdaf10751e1137a3f15 py3-ldap3-2.8.tar.gz"
+sha512sums="
+bf07ebca9a53a8c225bc3106d3bd45eb26557c6e5a3d6d45a7f8c149d938ad43825eed0d406a57b93e2e675ed7aa262828f022ab82eb683f0e3029e3ad823106 py3-ldap3-2.9.1.tar.gz
+"