aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-liac-arff/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-liac-arff/APKBUILD')
-rw-r--r--community/py3-liac-arff/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/py3-liac-arff/APKBUILD b/community/py3-liac-arff/APKBUILD
new file mode 100644
index 00000000000..a74795bb172
--- /dev/null
+++ b/community/py3-liac-arff/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+pkgname=py3-liac-arff
+_pkgorig=liac-arff
+pkgver=2.5.0
+pkgrel=4
+pkgdesc="A library for read and write ARFF files in Python"
+url="https://github.com/renatopp/liac-arff"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest-xdist"
+subpackages="$pkgname-pyc"
+source="https://github.com/renatopp/liac-arff/archive/v$pkgver/$_pkgorig-$pkgver.tar.gz
+ python-3.12.patch"
+builddir="$srcdir/$_pkgorig-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+fff5a6cda089ebe3cbd96861911bd3ddc36b0556f3c648b37bf7c74f353098dc37f0cb882f22f8b58731936cf517b00974f6772e91732fad76eb43855bd6c0df liac-arff-2.5.0.tar.gz
+65b4026e227f8d66b2c411105c0775531c6473cc7d48e8227ffcbe1ccc663f2401379835c30283f24d8436f44e53112593dfcec02590c7be13dc2621a2e006c6 python-3.12.patch
+"