aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-libevdev/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-libevdev/APKBUILD')
-rw-r--r--community/py3-libevdev/APKBUILD11
1 files changed, 6 insertions, 5 deletions
diff --git a/community/py3-libevdev/APKBUILD b/community/py3-libevdev/APKBUILD
index 28496e4f4d7..862b655b4f4 100644
--- a/community/py3-libevdev/APKBUILD
+++ b/community/py3-libevdev/APKBUILD
@@ -1,9 +1,9 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Will Sinatra <wpsinatra@gmail.com>
pkgname=py3-libevdev
_pyname=python-libevdev
-pkgver=0.9
-pkgrel=1
+pkgver=0.11
+pkgrel=3
pkgdesc="Python3 wrapper around the evdev library"
url="https://python-libevdev.readthedocs.io/en/latest"
arch="noarch"
@@ -11,6 +11,7 @@ license="MIT"
depends="libevdev python3"
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://gitlab.freedesktop.org/libevdev/$_pyname/-/archive/$pkgver/$_pyname-$pkgver.tar.gz"
builddir="$srcdir/$_pyname-$pkgver"
@@ -23,7 +24,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="8b61b7b5d7f2ccc7c510afa321e048c0b1a77cf6d646d611269c75787ed4fcdb70d463dfdc7bf62b260788db3695a9797fa5809c5ff4d0441180dc31028a3b2a py3-libevdev-0.9.tar.gz"
+sha512sums="224e2d18915f08d9f02e32845968e0e2eac531ad7f4efe5401de692cdb0980049f3cfd9cb869319e7526dbefd38144ab6e0b52ceba67ab371045ce60d21286da py3-libevdev-0.11.tar.gz"