aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-libvirt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-libvirt/APKBUILD')
-rw-r--r--community/py3-libvirt/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/py3-libvirt/APKBUILD b/community/py3-libvirt/APKBUILD
new file mode 100644
index 00000000000..2ceff53f694
--- /dev/null
+++ b/community/py3-libvirt/APKBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
+pkgname=py3-libvirt
+_pkgname=libvirt-python
+pkgver=10.2.0
+pkgrel=1
+pkgdesc="The libvirt virtualization API python binding"
+url="https://libvirt.org/"
+arch="all"
+license="LGPL-2.0-or-later"
+makedepends="
+ libvirt-dev
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="py3-pytest-xdist py3-lxml"
+subpackages="$pkgname-pyc"
+source="https://libvirt.org/sources/python/$_pkgname-$pkgver.tar.gz
+ disable-screenshot-test.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+
+replaces="py-libvirt" # Backwards compatibility
+provides="py-libvirt=$pkgver" # Backwards compatibility
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+36c79491a9be24fc118cbaddcd96c02c7df05c3808cd8f7dbc2d143330aa8f4a6cf8ea90fc1901dcb43d9c2b52edd1a013d01b88a82b1d3ec6a2ab88b671ac61 libvirt-python-10.2.0.tar.gz
+3d1d62a5d5283e5679dd1318a335b2785c895499f1fedae5d75947e29b0a55f6e4925108cf74e6b36f1c9f140aaf5c89171b84d8e94b1c3d3fc6fdc8c7f2f5fc disable-screenshot-test.patch
+"