aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-libvirt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-libvirt/APKBUILD')
-rw-r--r--community/py3-libvirt/APKBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/community/py3-libvirt/APKBUILD b/community/py3-libvirt/APKBUILD
index dbb8c769a88..2ceff53f694 100644
--- a/community/py3-libvirt/APKBUILD
+++ b/community/py3-libvirt/APKBUILD
@@ -1,15 +1,21 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=py3-libvirt
_pkgname=libvirt-python
-pkgver=7.5.0
-pkgrel=0
+pkgver=10.2.0
+pkgrel=1
pkgdesc="The libvirt virtualization API python binding"
-url="http://libvirt.org"
-# s390x, mips64 and riscv64 blocked by polkit -> libvirt
-arch="all !s390x !mips64 !riscv64"
+url="https://libvirt.org/"
+arch="all"
license="LGPL-2.0-or-later"
-makedepends="py3-setuptools python3-dev libvirt-dev"
-checkdepends="py3-pytest"
+makedepends="
+ libvirt-dev
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+checkdepends="py3-pytest-xdist py3-lxml"
+subpackages="$pkgname-pyc"
source="https://libvirt.org/sources/python/$_pkgname-$pkgver.tar.gz
disable-screenshot-test.patch"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -18,18 +24,23 @@ replaces="py-libvirt" # Backwards compatibility
provides="py-libvirt=$pkgver" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-ae111e4b7db5662af5315642232e2308ebc349bf80a3f9fd372b0fa0ebcde8e25690368187c86d425faef397550caad3366e7b6a3e6a0c4b56fa58df5e8bc276 libvirt-python-7.5.0.tar.gz
+36c79491a9be24fc118cbaddcd96c02c7df05c3808cd8f7dbc2d143330aa8f4a6cf8ea90fc1901dcb43d9c2b52edd1a013d01b88a82b1d3ec6a2ab88b671ac61 libvirt-python-10.2.0.tar.gz
3d1d62a5d5283e5679dd1318a335b2785c895499f1fedae5d75947e29b0a55f6e4925108cf74e6b36f1c9f140aaf5c89171b84d8e94b1c3d3fc6fdc8c7f2f5fc disable-screenshot-test.patch
"