aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-listparser/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-listparser/APKBUILD')
-rw-r--r--community/py3-listparser/APKBUILD16
1 files changed, 9 insertions, 7 deletions
diff --git a/community/py3-listparser/APKBUILD b/community/py3-listparser/APKBUILD
index 84ffa1d45a4..3da96277d3c 100644
--- a/community/py3-listparser/APKBUILD
+++ b/community/py3-listparser/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
-# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-listparser
-pkgver=0.18
-pkgrel=0
+pkgver=0.19
+pkgrel=3
pkgdesc="Parse OPML, FOAF, and iGoogle subscription lists"
url="https://github.com/kurtmckee/listparser"
arch="noarch"
license="GPL-3.0-or-later"
-depends="python3"
-depends="py3-six py3-requests"
+depends="python3 py3-requests"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/l/listparser/listparser-$pkgver.tar.gz"
builddir="$srcdir/listparser-$pkgver"
@@ -22,7 +22,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="3f76e1f9ac2011a4ad800332d838ea0e10e445cddead7829d049067534a60ce5c5180d49411108ae0769141cb55cd272a8945261d20e442ba06a84515867a80e listparser-0.18.tar.gz"
+sha512sums="
+7c56ca1711c94fa4936cb6d0e1214270fe2e5756c57981ed16f5cf7b3ce6ffce28fd21bb2085ccd002eb47df6740a6b9c427c8acf0f7d56883d487fe5f8847b8 listparser-0.19.tar.gz
+"