aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-lmdb/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-lmdb/APKBUILD')
-rw-r--r--community/py3-lmdb/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/community/py3-lmdb/APKBUILD b/community/py3-lmdb/APKBUILD
index fd6100d8fd6..e44ca98c048 100644
--- a/community/py3-lmdb/APKBUILD
+++ b/community/py3-lmdb/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-lmdb
pkgver=1.2.1
-pkgrel=1
+pkgrel=5
pkgdesc="Universal Python binding for the LMDB 'Lightning' Database"
url="https://github.com/jnwatson/py-lmdb/"
arch="all"
@@ -14,6 +14,7 @@ makedepends="
python3-dev
"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://github.com/jnwatson/py-lmdb/archive/py-lmdb_$pkgver.tar.gz
0001-make-map-resize-test-more-robust-for-weird-page-size-oss.patch
"
@@ -29,7 +30,7 @@ check() {
}
package() {
- LMDB_FORCE_SYSTEM=1 python3 setup.py install --prefix=/usr --root="$pkgdir"
+ LMDB_FORCE_SYSTEM=1 python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="