aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-locket/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-locket/APKBUILD')
-rw-r--r--community/py3-locket/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/py3-locket/APKBUILD b/community/py3-locket/APKBUILD
index bb49f3ccbc2..83a9e17ae62 100644
--- a/community/py3-locket/APKBUILD
+++ b/community/py3-locket/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-locket
-pkgver=0.2.1
-pkgrel=2
+pkgver=1.0.0
+pkgrel=3
pkgdesc="File-based locks for Python"
url="https://github.com/mwilliamson/locket.py"
arch="noarch"
license="BSD-2-Clause"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/l/locket/locket-$pkgver.tar.gz"
options="!check" # Release tarball doesn't contain the tests
builddir="$srcdir/locket-$pkgver"
@@ -18,7 +19,9 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="db25454b83d176f529eb3060e4e7fff0151d8a7ccfd58a66c9bc09345445923137c2e5eb7e8a42b9d8f1bbdb3a967cb3467e91a279f19ede6f8727eaebf85857 locket-0.2.1.tar.gz"
+sha512sums="
+9b41bbc39864f7c9eb4bfeae62c000bea1d1c0fac1320317ef4b4d02add3e1c3ae599e8c9c24fe1d1ac716fa1befc1bf76b748399927cb86be237763a9bed44b locket-1.0.0.tar.gz
+"