aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-locket/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-locket/APKBUILD')
-rw-r--r--community/py3-locket/APKBUILD11
1 files changed, 7 insertions, 4 deletions
diff --git a/community/py3-locket/APKBUILD b/community/py3-locket/APKBUILD
index 62694c5207f..83a9e17ae62 100644
--- a/community/py3-locket/APKBUILD
+++ b/community/py3-locket/APKBUILD
@@ -1,14 +1,15 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-locket
-pkgver=0.2.0
-pkgrel=0
+pkgver=1.0.0
+pkgrel=3
pkgdesc="File-based locks for Python"
url="https://github.com/mwilliamson/locket.py"
arch="noarch"
license="BSD-2-Clause"
depends="python3"
makedepends="py3-setuptools"
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/l/locket/locket-$pkgver.tar.gz"
options="!check" # Release tarball doesn't contain the tests
builddir="$srcdir/locket-$pkgver"
@@ -18,7 +19,9 @@ build() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="ed9bb25f3fcaa70386217716db5612bf31a923c669cbdb8e871de6df4c0c42bf3309604a1aac804c0f334aed8c88b0ba113d8d265054c0e87793c7b53f729ff9 locket-0.2.0.tar.gz"
+sha512sums="
+9b41bbc39864f7c9eb4bfeae62c000bea1d1c0fac1320317ef4b4d02add3e1c3ae599e8c9c24fe1d1ac716fa1befc1bf76b748399927cb86be237763a9bed44b locket-1.0.0.tar.gz
+"