aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-loky/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-loky/APKBUILD')
-rw-r--r--community/py3-loky/APKBUILD23
1 files changed, 16 insertions, 7 deletions
diff --git a/community/py3-loky/APKBUILD b/community/py3-loky/APKBUILD
index 8e63594e306..e43c5c8c476 100644
--- a/community/py3-loky/APKBUILD
+++ b/community/py3-loky/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer:
pkgname=py3-loky
-pkgver=2.9.0
-pkgrel=2
+pkgver=3.4.1
+pkgrel=1
pkgdesc="Robust implementation of concurrent.futures.ProcessPoolExecutor"
url="https://loky.readthedocs.io/en/stable/"
-arch="noarch !mips64" # py3-cloudpickle->py3-numpy
+arch="noarch"
license="BSD-3-Clause"
depends="python3 py3-cloudpickle"
makedepends="py3-setuptools"
checkdepends="py3-pytest py3-psutil"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/joblib/loky/archive/$pkgver.tar.gz"
builddir="$srcdir/loky-$pkgver"
@@ -18,7 +19,7 @@ build() {
}
check() {
- PYTHONPATH="$PWD/build/lib" py.test-3 -v \
+ PYTHONPATH="$PWD/build/lib" pytest -v \
--deselect tests/test_loky_backend.py::TestLokyBackend::test_sync_object_handling \
--deselect tests/test_reusable_executor.py::TestGetReusableExecutor::test_invalid_process_number \
--deselect tests/test_reusable_executor.py::TestGetReusableExecutor::test_reusable_executor_thread_safety[constant-clean_start] \
@@ -29,11 +30,19 @@ check() {
--deselect tests/test_reusable_executor.py::TestExecutorInitializer::test_reusable_initializer \
--deselect tests/test_process_executor_forkserver.py::TestsProcessPoolForkserverExecutor::test_no_failure_on_large_data_send \
--deselect tests/test_process_executor_loky.py::TestsProcessPoolLokyExecutor::test_no_failure_on_large_data_send \
- --deselect tests/test_process_executor_spawn.py::TestsProcessPoolSpawnExecutor::test_no_failure_on_large_data_send
+ --deselect tests/test_process_executor_spawn.py::TestsProcessPoolSpawnExecutor::test_no_failure_on_large_data_send \
+ --deselect tests/test_loky_backend.py::test_recursive_terminate \
+ --deselect tests/test_resource_tracker.py::TestResourceTracker::test_resource_tracker_sigkill \
+ --deselect tests/test_reusable_executor.py::TestExecutorDeadLock::test_deadlock_kill \
+ --deselect tests/test_reusable_executor.py::TestResizeExecutor::test_resize_after_timeout \
+ --deselect tests/test_reusable_executor.py::test_no_crash_max_workers_on_windows \
+ --deselect tests/test_worker_timeout.py::TestTimeoutExecutor::test_worker_timeout_shutdown_no_deadlock
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="d49354b834251f6f05a689ac44464aafa5a7a5b4a8ef84a308ec3bda138e810fc3dc31aa628307984dc69386a210f442d4c202b9499ae3e3864837b47a5b0cd9 py3-loky-2.9.0.tar.gz"
+sha512sums="
+435dc24a0532e6a40a67613fd1e13a06439ffe00c28b90fa36ff02255b67e0dd99d515f5659a36aa1049a9df73b16c1088989a1379a8492ebc5dbf1e53a37a06 py3-loky-3.4.1.tar.gz
+"