aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-lsp-server/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-lsp-server/APKBUILD')
-rw-r--r--community/py3-lsp-server/APKBUILD47
1 files changed, 34 insertions, 13 deletions
diff --git a/community/py3-lsp-server/APKBUILD b/community/py3-lsp-server/APKBUILD
index f854f3dddcf..0bd214db38e 100644
--- a/community/py3-lsp-server/APKBUILD
+++ b/community/py3-lsp-server/APKBUILD
@@ -1,14 +1,26 @@
# Contributor: Clayton Craft <clayton@craftyguy.net>
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=py3-lsp-server
-pkgver=1.2.4
-pkgrel=0
+pkgver=1.10.1
+pkgrel=1
pkgdesc="python implementation of the language server protocol, fork of python-language-server"
url="https://github.com/python-lsp/python-lsp-server"
-arch="noarch !armhf" # no py3-qt
+arch="noarch !armhf !s390x" # armhf: no py3-qt, s390x: no py3-pylint
license="MIT"
-depends="py3-jedi py3-pluggy py3-ujson py3-lsp-jsonrpc py3-pydocstyle python3"
-makedepends="py3-setuptools"
+depends="
+ py3-docstring-to-markdown
+ py3-jedi
+ py3-lsp-jsonrpc
+ py3-pluggy
+ py3-setuptools
+ py3-ujson
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools_scm
+ py3-wheel
+ "
checkdepends="
py3-autopep8
py3-flake8
@@ -25,27 +37,36 @@ checkdepends="
py3-python-versioneer
py3-qt5
py3-rope
+ py3-toml
+ py3-whatthepatch
py3-yapf
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/python-lsp/python-lsp-server/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/python-lsp-server/python-lsp-server-$pkgver.tar.gz"
builddir="$srcdir/python-lsp-server-$pkgver"
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
# deselect'ed tests are broken
- pytest -v test/ \
- --deselect test/plugins/test_flake8_lint.py \
- --deselect test/plugins/test_pylint_lint.py \
- -k "not test_jedi_completion_environment and not test_symbols_all_scopes_with_jedi_environment"
+ # pydocstyle is no longer maintaned upstream
+ .testenv/bin/python3 -m pytest \
+ --ignore test/plugins/test_pydocstyle_lint.py \
+ -k 'not test_jedi_completion_environment and not test_symbols_all_scopes_with_jedi_environment'
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-2f2a9e941eed7ec99b1b48fb8a56b321c6af0b3a05c7e3b5377a84afb1bb7e8ad167783227a9cda9d993b8ee0cee941f7d5fb4334abff6cc89787cfba3678098 py3-lsp-server-1.2.4.tar.gz
+4c8e6a72ef6004248a5cb4a1e4c251b9d487cd4ce39d6c7268ce611c8537d6a5912eeb49d2eb1a25c230934b17e9a624504591c25f0291e07971eeccb70b09ba python-lsp-server-1.10.1.tar.gz
"