aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-lsp-server/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-lsp-server/APKBUILD')
-rw-r--r--community/py3-lsp-server/APKBUILD49
1 files changed, 37 insertions, 12 deletions
diff --git a/community/py3-lsp-server/APKBUILD b/community/py3-lsp-server/APKBUILD
index e94efc1c6ab..ffd5d1e4578 100644
--- a/community/py3-lsp-server/APKBUILD
+++ b/community/py3-lsp-server/APKBUILD
@@ -1,14 +1,26 @@
# Contributor: Clayton Craft <clayton@craftyguy.net>
# Maintainer: Clayton Craft <clayton@craftyguy.net>
pkgname=py3-lsp-server
-pkgver=1.2.2
+pkgver=1.11.0
pkgrel=0
pkgdesc="python implementation of the language server protocol, fork of python-language-server"
url="https://github.com/python-lsp/python-lsp-server"
-arch="noarch !armhf" # no py3-qt
+arch="noarch !armhf !s390x" # armhf: no py3-qt, s390x: no py3-pylint
license="MIT"
-depends="py3-jedi py3-pluggy py3-ujson py3-lsp-jsonrpc py3-pydocstyle python3"
-makedepends="py3-setuptools"
+depends="
+ py3-docstring-to-markdown
+ py3-jedi
+ py3-lsp-jsonrpc
+ py3-pluggy
+ py3-setuptools
+ py3-ujson
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools_scm
+ py3-wheel
+ "
checkdepends="
py3-autopep8
py3-flake8
@@ -25,27 +37,40 @@ checkdepends="
py3-python-versioneer
py3-qt5
py3-rope
+ py3-toml
+ py3-whatthepatch
py3-yapf
"
-source="$pkgname-$pkgver.tar.gz::https://github.com/python-lsp/python-lsp-server/archive/v$pkgver.tar.gz"
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/python-lsp-server/python-lsp-server-$pkgver.tar.gz"
builddir="$srcdir/python-lsp-server-$pkgver"
build() {
- python3 setup.py build
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ local k="not test_jedi_completion_environment"
+ k="$k and not test_symbols_all_scopes_with_jedi_environment"
+ # fails on riscv64
+ k="$k and not test_autoimport_code_actions_and_completions_for_notebook_document"
# deselect'ed tests are broken
- pytest -v test/ \
- --deselect test/plugins/test_flake8_lint.py \
- --deselect test/plugins/test_pylint_lint.py \
- -k "not test_jedi_completion_environment and not test_symbols_all_scopes_with_jedi_environment"
+ # pydocstyle is no longer maintaned upstream
+ .testenv/bin/python3 -m pytest \
+ --ignore test/plugins/test_pydocstyle_lint.py \
+ -k "$k"
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-51ed572807bca809b7605ecadec110569d2d4ee3590de59a24d29a6dc4fcf107eeecda46990a91312ccb551dcc75af32bd04daae0d07c1efb3f27212869d2c17 py3-lsp-server-1.2.2.tar.gz
+bd96850b822dc3c2e97d5ee38f25c9f7731dc68b31fedcc2d3e0ff373bc3ad8a989f1a4b85527477bbbc875e853d5513d8583bc3cdc22a3c0545716e68382093 python-lsp-server-1.11.0.tar.gz
"