aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-lsp-server/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-lsp-server/APKBUILD')
-rw-r--r--community/py3-lsp-server/APKBUILD76
1 files changed, 76 insertions, 0 deletions
diff --git a/community/py3-lsp-server/APKBUILD b/community/py3-lsp-server/APKBUILD
new file mode 100644
index 00000000000..062d7208fd3
--- /dev/null
+++ b/community/py3-lsp-server/APKBUILD
@@ -0,0 +1,76 @@
+# Contributor: Clayton Craft <clayton@craftyguy.net>
+# Maintainer: Clayton Craft <clayton@craftyguy.net>
+pkgname=py3-lsp-server
+pkgver=1.10.1
+pkgrel=1
+pkgdesc="python implementation of the language server protocol, fork of python-language-server"
+url="https://github.com/python-lsp/python-lsp-server"
+arch="noarch !armhf !s390x" # armhf: no py3-qt, s390x: no py3-pylint
+license="MIT"
+depends="
+ py3-docstring-to-markdown
+ py3-jedi
+ py3-lsp-jsonrpc
+ py3-pluggy
+ py3-setuptools
+ py3-ujson
+ python3
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools_scm
+ py3-wheel
+ "
+checkdepends="
+ py3-autopep8
+ py3-flake8
+ py3-flaky
+ py3-matplotlib
+ py3-mccabe
+ py3-numpy
+ py3-pandas
+ py3-pycodestyle
+ py3-pyflakes
+ py3-pylint
+ py3-pytest
+ py3-pytest-cov
+ py3-python-versioneer
+ py3-qt5
+ py3-rope
+ py3-toml
+ py3-whatthepatch
+ py3-yapf
+ "
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/p/python-lsp-server/python-lsp-server-$pkgver.tar.gz"
+builddir="$srcdir/python-lsp-server-$pkgver"
+
+build() {
+ export SETUPTOOLS_SCM_PRETEND_VERSION=$pkgver
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ local k="not test_jedi_completion_environment"
+ k="$k and not test_symbols_all_scopes_with_jedi_environment"
+ # fails on riscv64
+ k="$k and not test_autoimport_code_actions_and_completions_for_notebook_document"
+ # deselect'ed tests are broken
+ # pydocstyle is no longer maintaned upstream
+ .testenv/bin/python3 -m pytest \
+ --ignore test/plugins/test_pydocstyle_lint.py \
+ -k "$k"
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+}
+
+sha512sums="
+4c8e6a72ef6004248a5cb4a1e4c251b9d487cd4ce39d6c7268ce611c8537d6a5912eeb49d2eb1a25c230934b17e9a624504591c25f0291e07971eeccb70b09ba python-lsp-server-1.10.1.tar.gz
+"