aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-makefun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-makefun/APKBUILD')
-rw-r--r--[-rwxr-xr-x]community/py3-makefun/APKBUILD23
1 files changed, 15 insertions, 8 deletions
diff --git a/community/py3-makefun/APKBUILD b/community/py3-makefun/APKBUILD
index ae433c3c81b..2a6ccab676c 100755..100644
--- a/community/py3-makefun/APKBUILD
+++ b/community/py3-makefun/APKBUILD
@@ -1,35 +1,42 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=py3-makefun
-pkgver=1.13.1
-pkgrel=1
+pkgver=1.15.2
+pkgrel=3
pkgdesc="Small library to dynamically create python functions"
url="https://github.com/smarie/python-makefun"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
makedepends="
- py3-pytest
- py3-pytest-runner
+ py3-gpep517
py3-setuptools
py3-setuptools_scm
py3-wheel
"
+checkdepends="
+ py3-pytest
+ py3-pytest-runner
+ "
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/m/makefun/makefun-$pkgver.tar.gz"
builddir="$srcdir/makefun-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ PYTHONPATH="$PWD/src" pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/makefun-$pkgver*-py2.py3-none-any.whl
}
sha512sums="
-ae103d3827673c4124d051e3c76d3d0d126c783ac7a1ea09de3801fd695439eaa549c297bd5c262184a3ee6fdf7b046065081fa3183642778148c2134d7bfc06 makefun-1.13.1.tar.gz
+b6cb588ebf491176b06e97201846b2a5cee65f60e34b5dbcc4878d8a55e7f9fcf4b58126cb3a4ca47f5d2726422dff9ee685566c5d093dbd8fd75119ecc796b2 makefun-1.15.2.tar.gz
"