aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-makefun/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-makefun/APKBUILD')
-rw-r--r--[-rwxr-xr-x]community/py3-makefun/APKBUILD26
1 files changed, 20 insertions, 6 deletions
diff --git a/community/py3-makefun/APKBUILD b/community/py3-makefun/APKBUILD
index e4ebdca8a18..2a6ccab676c 100755..100644
--- a/community/py3-makefun/APKBUILD
+++ b/community/py3-makefun/APKBUILD
@@ -1,28 +1,42 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=py3-makefun
-pkgver=1.11.3
-pkgrel=0
+pkgver=1.15.2
+pkgrel=3
pkgdesc="Small library to dynamically create python functions"
url="https://github.com/smarie/python-makefun"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
makedepends="
+ py3-gpep517
py3-setuptools
py3-setuptools_scm
+ py3-wheel
"
+checkdepends="
+ py3-pytest
+ py3-pytest-runner
+ "
+subpackages="$pkgname-pyc"
source="https://pypi.python.org/packages/source/m/makefun/makefun-$pkgver.tar.gz"
builddir="$srcdir/makefun-$pkgver"
-options="!check" # No testsuite
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ PYTHONPATH="$PWD/src" pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/makefun-$pkgver*-py2.py3-none-any.whl
}
+
sha512sums="
-ec522fc26b41b19afd17383e6da34cea06b8a4d40936373ebec6060ab9c4941bcea6dc24642dbef3a3719edee63b427fd13c01bc72fc2385ce3a7ad4be7dc952 makefun-1.11.3.tar.gz
+b6cb588ebf491176b06e97201846b2a5cee65f60e34b5dbcc4878d8a55e7f9fcf4b58126cb3a4ca47f5d2726422dff9ee685566c5d093dbd8fd75119ecc796b2 makefun-1.15.2.tar.gz
"