aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-matrix-common/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-matrix-common/APKBUILD')
-rw-r--r--community/py3-matrix-common/APKBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/community/py3-matrix-common/APKBUILD b/community/py3-matrix-common/APKBUILD
new file mode 100644
index 00000000000..44523d9c54b
--- /dev/null
+++ b/community/py3-matrix-common/APKBUILD
@@ -0,0 +1,41 @@
+# Contributor: 6543 <6543@obermui.de>
+# Maintainer: 6543 <6543@obermui.de>
+pkgname=py3-matrix-common
+pkgver=1.3.0
+pkgrel=3
+pkgdesc="Common utilities for Synapse, Sydent and Sygnal"
+url="https://github.com/matrix-org/matrix-python-common"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 py3-attrs"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="py3-twisted"
+subpackages="$pkgname-pyc"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/matrix-org/matrix-python-common/archive/refs/tags/v$pkgver.tar.gz
+ "
+builddir="$srcdir/matrix-python-common-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m twisted.trial tests
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+d08fa11a4156a7c4596ea20709e0fddd1563ef1f4ba763e21a073ba53e1baf58d8de1b60cf0f69c846128cdd6f04788df49765704c8adfde187e8de1dc5ded4e py3-matrix-common-1.3.0.tar.gz
+"