aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-matrix-common/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-matrix-common/APKBUILD')
-rw-r--r--community/py3-matrix-common/APKBUILD28
1 files changed, 15 insertions, 13 deletions
diff --git a/community/py3-matrix-common/APKBUILD b/community/py3-matrix-common/APKBUILD
index 7454b0f928a..44523d9c54b 100644
--- a/community/py3-matrix-common/APKBUILD
+++ b/community/py3-matrix-common/APKBUILD
@@ -1,39 +1,41 @@
-# Contributor:
-# Maintainer:
+# Contributor: 6543 <6543@obermui.de>
+# Maintainer: 6543 <6543@obermui.de>
pkgname=py3-matrix-common
-pkgver=1.1.0
-pkgrel=1
+pkgver=1.3.0
+pkgrel=3
pkgdesc="Common utilities for Synapse, Sydent and Sygnal"
url="https://github.com/matrix-org/matrix-python-common"
arch="noarch"
license="Apache-2.0"
-depends="python3"
depends="python3 py3-attrs"
makedepends="
- py3-build
- py3-installer
+ py3-gpep517
py3-setuptools
py3-wheel
"
-checkdepends="py3-pytest"
+checkdepends="py3-twisted"
+subpackages="$pkgname-pyc"
source="
$pkgname-$pkgver.tar.gz::https://github.com/matrix-org/matrix-python-common/archive/refs/tags/v$pkgver.tar.gz
"
builddir="$srcdir/matrix-python-common-$pkgver"
build() {
- python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m twisted.trial tests
}
package() {
- python3 -m installer -d "$pkgdir" \
- dist/matrix_common-$pkgver-py3-none-any.whl
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
sha512sums="
-22cb3844f4e442e92c1a1dc1e5d0559525c0e375063a5adb0fe7c7b5051d94cbdeb114ee12acf84ffc97e4fd9b351417a6a624fd156c98acee5dc1bb650eb2a7 py3-matrix-common-1.1.0.tar.gz
+d08fa11a4156a7c4596ea20709e0fddd1563ef1f4ba763e21a073ba53e1baf58d8de1b60cf0f69c846128cdd6f04788df49765704c8adfde187e8de1dc5ded4e py3-matrix-common-1.3.0.tar.gz
"