aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-matrix-nio/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-matrix-nio/APKBUILD')
-rw-r--r--community/py3-matrix-nio/APKBUILD46
1 files changed, 26 insertions, 20 deletions
diff --git a/community/py3-matrix-nio/APKBUILD b/community/py3-matrix-nio/APKBUILD
index 305d50c5f1a..c3c03f4ece3 100644
--- a/community/py3-matrix-nio/APKBUILD
+++ b/community/py3-matrix-nio/APKBUILD
@@ -1,62 +1,68 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Celeste <cielesti@protonmail.com>
pkgname=py3-matrix-nio
-pkgver=0.15.2
+pkgver=0.24.0
pkgrel=1
-pkgdesc="Python interface to DBus notifications"
+pkgdesc="Python Matrix client library"
url="https://github.com/poljar/matrix-nio"
-arch="noarch !mips64" # blocked by py3-olm
+arch="noarch"
license="ISC"
depends="
- python3
py3-aiofiles
py3-aiohttp
- py3-atomicwrites
- py3-cachetools
- py3-future
+ py3-aiohttp-socks
py3-h11
py3-h2
py3-jsonschema
py3-logbook
- py3-olm
- py3-peewee
py3-pycryptodome
py3-unpaddedbase64
"
checkdepends="
py3-aioresponses
+ py3-atomicwrites
+ py3-cachetools
py3-faker
py3-hpack
py3-hyperframe
py3-hypothesis
py3-mypy
+ py3-olm
+ py3-peewee
py3-pytest
py3-pytest-aiohttp
+ py3-pytest-asyncio
py3-pytest-benchmark
py3-pytest-cov
py3-pytest-isort
- "
-makedepends="
py3-setuptools
"
-source="
- https://github.com/poljar/matrix-nio/archive/$pkgver/matrix-nio-$pkgver.tar.gz
- 0001-CI-Fix-our-tox-setup-for-github-CI.patch
+makedepends="
+ py3-gpep517
+ py3-poetry-core
"
+subpackages="$pkgname-pyc"
+source="https://github.com/poljar/matrix-nio/archive/$pkgver/matrix-nio-$pkgver.tar.gz"
builddir="$srcdir/matrix-nio-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
# test_connect_wrapper requires a network connection
- PYTHONPATH="$PWD/build/lib" pytest -k 'not test_connect_wrapper'
+ .testenv/bin/python3 -m pytest -k 'not test_connect_wrapper'
+
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" .dist/*.whl
}
-sha512sums="2805ac328425b5686320da969838d865d6ab17ede59b372ff9c04923ac246aa86a552e480b305c4769524f599393d6cc4a7ff75bae250d3cfebff8b8b9ed710e matrix-nio-0.15.2.tar.gz
-6f339ccccefda38fac0c21b195eaf84d18a03d42a5fc635213d4e786e4501a5535281bc244180797b3280b9440f6ab67fd764bdd2e522eb9da9a098502067f23 0001-CI-Fix-our-tox-setup-for-github-CI.patch"
+sha512sums="
+b48b712b3fa75a251ff1f1689bf08feb5df993ec6f8112774a1c413d45e686f90ab6d7e5aa972acbd8a65af070716317aa361607c38e62282b640e7d514dbc08 matrix-nio-0.24.0.tar.gz
+"