aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-mdurl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-mdurl/APKBUILD')
-rw-r--r--community/py3-mdurl/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/py3-mdurl/APKBUILD b/community/py3-mdurl/APKBUILD
index bb7a55e4c74..646f119e05e 100644
--- a/community/py3-mdurl/APKBUILD
+++ b/community/py3-mdurl/APKBUILD
@@ -1,20 +1,23 @@
# Contributor: Patrycja Rosa <alpine@ptrcnull.me>
# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-mdurl
-pkgver=0.1.1
-pkgrel=0
+pkgver=0.1.2
+pkgrel=3
pkgdesc="URL utilities for markdown-it (a Python port)"
url="https://github.com/executablebooks/mdurl"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-build py3-flit py3-installer"
+makedepends="py3-gpep517 py3-flit-core"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="https://github.com/executablebooks/mdurl/archive/$pkgver/py3-mdurl-$pkgver.tar.gz"
builddir="$srcdir/mdurl-$pkgver"
build() {
- python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -22,9 +25,9 @@ check() {
}
package() {
- python3 -m installer -d "$pkgdir" dist/mdurl-$pkgver-py3-none-any.whl
+ python3 -m installer -d "$pkgdir" .dist/mdurl-$pkgver-py3-none-any.whl
}
sha512sums="
-ae7ee5672f59595d96fa3fd8b45154d3175881432dea60c72ef6dbd0b22124a20183539c83552bb9a8dfa1fc1c4ac3132201ce389a6678853c55c0224aa04622 py3-mdurl-0.1.1.tar.gz
+e301ca3ab6d80df1ad28b9c2725d66b6e6cf139d93e5f7fd2a70333678616a3f6db64f15250972eee3cd1cf1eaff6ec587415629e6802dcf07995edff6865ff2 py3-mdurl-0.1.2.tar.gz
"