aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-mechanize/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-mechanize/APKBUILD')
-rw-r--r--community/py3-mechanize/APKBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/community/py3-mechanize/APKBUILD b/community/py3-mechanize/APKBUILD
index 96b81f6fe6c..3ec15a38b28 100644
--- a/community/py3-mechanize/APKBUILD
+++ b/community/py3-mechanize/APKBUILD
@@ -2,27 +2,35 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-mechanize
_pkgname=mechanize
-pkgver=0.4.5
-pkgrel=1
+pkgver=0.4.9
+pkgrel=0
pkgdesc="Stateful programmatic web browsing in Python"
url="https://github.com/python-mechanize/mechanize"
arch="noarch"
license="BSD-3-Clause"
-depends="python3"
-makedepends="py3-setuptools"
+depends="py3-html5lib python3"
+makedepends="py3-gpep517 py3-setuptools py3-wheel"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py check
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 run_tests.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="51706d5c073501d02fb7395eda30625ed9191324f948073c7d1589df0e507d8b7641ca514ceff55e7d82e899ba6e10c55507c79668976c7654ff0004671d09d2 mechanize-0.4.5.tar.gz"
+sha512sums="
+a0c5d6e01ddabd35dded9908e4f7e24cb0a8c20a674af603cd2f5f146c75d38dc96c36af0898646691206ce41745dff9a736ce53efd03ff48e55e763814b893c mechanize-0.4.9.tar.gz
+"