aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-minimock/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-minimock/APKBUILD')
-rw-r--r--community/py3-minimock/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/community/py3-minimock/APKBUILD b/community/py3-minimock/APKBUILD
new file mode 100644
index 00000000000..ee5c4ef5052
--- /dev/null
+++ b/community/py3-minimock/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Noel Kuntze <noel.kuntze@thermi.consulting>
+# Maintainer: Oliver Smith <ollieparanoid@postmarketos.org>
+pkgname=py3-minimock
+pkgver=1.2.8
+pkgrel=5
+pkgdesc="Simple mock library"
+url="https://pypi.org/project/MiniMock/"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+checkdepends="py3-nose"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/lowks/minimock/archive/$pkgver.tar.gz"
+builddir="$srcdir/minimock-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ sh test
+}
+
+package() {
+ python3 setup.py install --root="$pkgdir"
+}
+
+sha512sums="dd12154470263132c4fc8860796619e0db736c9482d8bbdffeba305f846ad873596bf500becef65a812e7a41385471b3d74fe7b7064e9fe255eb7c69a05bfd7e py3-minimock-1.2.8.tar.gz"