aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-mistune/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-mistune/APKBUILD')
-rw-r--r--community/py3-mistune/APKBUILD28
1 files changed, 20 insertions, 8 deletions
diff --git a/community/py3-mistune/APKBUILD b/community/py3-mistune/APKBUILD
index d65516ffa91..b2807f43295 100644
--- a/community/py3-mistune/APKBUILD
+++ b/community/py3-mistune/APKBUILD
@@ -1,28 +1,40 @@
# Contributor: Newbyte <newbie13xd@gmail.com>
# Maintainer: Newbyte <newbie13xd@gmail.com>
pkgname=py3-mistune
-pkgver=0.8.4
-pkgrel=2
+pkgver=3.0.2
+pkgrel=1
pkgdesc="Python Markdown parser module"
url="https://github.com/lepture/mistune"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
-makedepends="py3-setuptools"
-checkdepends="py3-nose"
+makedepends="py3-gpep517 py3-installer py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/lepture/mistune/archive/v$pkgver.tar.gz"
builddir="$srcdir/mistune-$pkgver"
+# secfixes:
+# 2.0.3-r0:
+# - CVE-2022-34749
+
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="44f155966e135ae157a8769e566119d86d1cdae28a4c27ecb54c33a9497096d0d4284a98da0c1bd47195f1b5c83e293b9655a912431adb18bfe84766ba1adc15 py3-mistune-0.8.4.tar.gz"
+sha512sums="
+c3075f5834e200a900f31478eb652745e3cce4e9cbc25796b65fe3998bdfa05eef327bb851aefd7128577660c3f48982d36bb2cec2d8d2a6fbb64dee2516b57b py3-mistune-3.0.2.tar.gz
+"