aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-mistune/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-mistune/APKBUILD')
-rw-r--r--community/py3-mistune/APKBUILD25
1 files changed, 17 insertions, 8 deletions
diff --git a/community/py3-mistune/APKBUILD b/community/py3-mistune/APKBUILD
index 03b3d3ea0e9..b2807f43295 100644
--- a/community/py3-mistune/APKBUILD
+++ b/community/py3-mistune/APKBUILD
@@ -1,31 +1,40 @@
# Contributor: Newbyte <newbie13xd@gmail.com>
# Maintainer: Newbyte <newbie13xd@gmail.com>
pkgname=py3-mistune
-pkgver=2.0.2
-pkgrel=0
+pkgver=3.0.2
+pkgrel=1
pkgdesc="Python Markdown parser module"
url="https://github.com/lepture/mistune"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
-makedepends="py3-build py3-installer py3-setuptools py3-wheel"
-checkdepends="py3-nose py3-pytest"
+makedepends="py3-gpep517 py3-installer py3-setuptools py3-wheel"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/lepture/mistune/archive/v$pkgver.tar.gz"
builddir="$srcdir/mistune-$pkgver"
+# secfixes:
+# 2.0.3-r0:
+# - CVE-2022-34749
+
build() {
- python3 -m build --no-isolation --wheel
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
python3 -m installer -d "$pkgdir" \
- dist/mistune-$pkgver-py2.py3-none-any.whl
+ .dist/*.whl
}
sha512sums="
-b11bda3f265a74959ea66b19bc0122f6951beb68af7eced1ff4c2106e179c65bba0566f7f7146e087307ca3f78ad0a1fdc78dc3955e6cb1ea2a0ce5c2e1aeecb py3-mistune-2.0.2.tar.gz
+c3075f5834e200a900f31478eb652745e3cce4e9cbc25796b65fe3998bdfa05eef327bb851aefd7128577660c3f48982d36bb2cec2d8d2a6fbb64dee2516b57b py3-mistune-3.0.2.tar.gz
"