aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-mpi4py/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-mpi4py/APKBUILD')
-rw-r--r--community/py3-mpi4py/APKBUILD29
1 files changed, 20 insertions, 9 deletions
diff --git a/community/py3-mpi4py/APKBUILD b/community/py3-mpi4py/APKBUILD
index 111cdfd7b40..9f8833b9f96 100644
--- a/community/py3-mpi4py/APKBUILD
+++ b/community/py3-mpi4py/APKBUILD
@@ -1,32 +1,43 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-mpi4py
-pkgver=3.0.3
+pkgver=3.1.5
pkgrel=1
pkgdesc="Python bindings for MPI"
-url="https://bitbucket.org/mpi4py/mpi4py/"
+url="https://github.com/mpi4py/mpi4py"
arch="all"
license="BSD-2-Clause"
-depends="python3"
makedepends="
+ openmpi
openmpi-dev
+ py3-gpep517
py3-setuptools
+ py3-wheel
python3-dev
"
-source="https://pypi.python.org/packages/source/m/mpi4py/mpi4py-$pkgver.tar.gz"
-options="!check" # Build errors
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="https://github.com/mpi4py/mpi4py/releases/download/$pkgver/mpi4py-$pkgver.tar.gz"
+options="!check" # Fails to collect tests
builddir="$srcdir/mpi4py-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="041768f753c8188b2560fe92711861780f0d77eda3281433520c98bb1e9b4da6a89c364f2d1c4623868ffbbcfde34ef556198b1bef6fc1c4a9c19cd5e71b546c mpi4py-3.0.3.tar.gz"
+sha512sums="
+04da1d6daf66cc86fa3ec574eea6e01749f895035e3394afbc68d6245394c5b03557ede0bda3642b06d9c6ff2c1e6e878a6c8c30d3fa3491392e2e13b82cdec8 mpi4py-3.1.5.tar.gz
+"