aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-mpv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-mpv/APKBUILD')
-rw-r--r--community/py3-mpv/APKBUILD27
1 files changed, 20 insertions, 7 deletions
diff --git a/community/py3-mpv/APKBUILD b/community/py3-mpv/APKBUILD
index 4841207b285..0e9a31ae3b6 100644
--- a/community/py3-mpv/APKBUILD
+++ b/community/py3-mpv/APKBUILD
@@ -1,24 +1,37 @@
# Contributor: Alex McGrath <amk@amk.ie>
# Maintainer: Alex McGrath <amk@amk.ie>
pkgname=py3-mpv
-pkgver=0.5.2
+pkgver=1.0.5
pkgrel=1
pkgdesc="Python interface to the mpv media player"
url="https://github.com/jaseg/python-mpv"
-arch="all"
+arch="noarch"
license="MIT"
depends="python3 mpv-libs"
-makedepends="py3-setuptools"
+makedepends="
+ py3-setuptools
+ py3-gpep517
+ py3-installer
+ py3-wheel
+ "
options="!check" # tests require unpackaged xvfbwrapper
-source="python-mpv-$pkgver.tar.gz::https://github.com/jaseg/python-mpv/archive/v$pkgver.tar.gz"
+
+# release 1.0.3 has a typo where the version is vv$pkgver rather than v$pkgver
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jaseg/python-mpv/archive/v$pkgver.tar.gz"
builddir="$srcdir/python-mpv-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="cd542b0866d6c75395f1ca00bb6df3981998dd801dcee97b15e080fe66e94270f15daa674f663aa6974dcf6aa425d6e17f8476031badeec035727b2b690816f3 python-mpv-0.5.2.tar.gz"
+sha512sums="
+cefc0b38146d707a06e2b9e58951675be8d236c95e24de7665085641b24f7d7d5303130ebdb4c97f4f4c79b6de393c30656d9fc0dabf6760156d4aca8207d77c py3-mpv-1.0.5.tar.gz
+"