aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-msgpack/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-msgpack/APKBUILD')
-rw-r--r--community/py3-msgpack/APKBUILD32
1 files changed, 15 insertions, 17 deletions
diff --git a/community/py3-msgpack/APKBUILD b/community/py3-msgpack/APKBUILD
index c1c0ffe81b4..c6370dbdc0a 100644
--- a/community/py3-msgpack/APKBUILD
+++ b/community/py3-msgpack/APKBUILD
@@ -2,15 +2,16 @@
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-msgpack
_pkgname=msgpack-python
-pkgver=0.6.2
+pkgver=1.0.8
pkgrel=1
pkgdesc="Python3 module for MessagePack serialization/deserialization"
url="https://msgpack.org/"
arch="all"
license="Apache-2.0"
depends="python3"
-makedepends="python3-dev py3-setuptools cython"
-checkdepends="py3-pytest py3-pluggy"
+makedepends="python3-dev py3-gpep517 py3-setuptools cython py3-wheel"
+checkdepends="py3-pytest-xdist py3-pluggy"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/msgpack/msgpack-python/archive/v$pkgver.tar.gz"
builddir="$srcdir/msgpack-python-$pkgver"
@@ -18,25 +19,22 @@ replaces="py-msgpack" # Backwards compatibility
provides="py-msgpack=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- local _pyarch
-
- case "$CARCH" in
- x86_64|aarch64|ppc64le) _pyarch="$CARCH" ;;
- x86) _pyarch=i686 ;;
- armhf|armv7) _pyarch=armv8l ;;
- s390x) _pyarch=s390x;;
- esac
-
- local _py3ver=$(python3 -c 'import sys; print("{}.{}".format(sys.version_info.major, sys.version_info.minor))')
- env PYTHONPATH="$PWD/build/lib.linux-$_pyarch-$_py3ver" pytest-3 test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="be4a65592acf3c2a4fcd5d6c603f5a3346f0bccb4864d82a729d47308a11d990f7137e66a9d6df7309a892d189f62e8a9efbda022b7ef2a09338012aa1634b6d msgpack-python-0.6.2.tar.gz"
+sha512sums="
+a4d37bbc5b640ef49cc44cd2cb99710b149c94c112fb92e26a30c72de3fa7e206430c3242b03c88527874bc10b13a9d1862f61d782f202a612e2496aef7a8dbb msgpack-python-1.0.8.tar.gz
+"