aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-msoffcrypto-tool/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-msoffcrypto-tool/APKBUILD')
-rw-r--r--community/py3-msoffcrypto-tool/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/community/py3-msoffcrypto-tool/APKBUILD b/community/py3-msoffcrypto-tool/APKBUILD
new file mode 100644
index 00000000000..62743a806fd
--- /dev/null
+++ b/community/py3-msoffcrypto-tool/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=py3-msoffcrypto-tool
+pkgver=5.3.1
+pkgrel=1
+pkgdesc="tool and library for decrypting MS Office files with passwords or other keys"
+url="https://github.com/nolze/msoffcrypto-tool"
+arch="noarch"
+license="MIT"
+depends="python3 py3-cryptography py3-olefile py3-setuptools"
+makedepends="py3-gpep517 py3-installer py3-poetry-core"
+checkdepends="bash py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/nolze/msoffcrypto-tool/archive/refs/tags/v$pkgver.tar.gz"
+builddir="$srcdir/msoffcrypto-tool-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ (
+ # shellcheck disable=1091
+ . .testenv/bin/activate
+ .testenv/bin/python3 -m pytest
+ )
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" .dist/*.whl
+}
+
+sha512sums="
+affebaec294cb9fb8cc2f7c808a7a8aca5adf15d83770b30db594bd1ce0d9229f010c307d54aa6f6cf02f696680dcf5cda13d2fe6e110b2a39d820ae1833dc51 py3-msoffcrypto-tool-5.3.1.tar.gz
+"