aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-mypy-extensions/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-mypy-extensions/APKBUILD')
-rw-r--r--community/py3-mypy-extensions/APKBUILD31
1 files changed, 21 insertions, 10 deletions
diff --git a/community/py3-mypy-extensions/APKBUILD b/community/py3-mypy-extensions/APKBUILD
index 303f5f8c0bc..b03220c9bb3 100644
--- a/community/py3-mypy-extensions/APKBUILD
+++ b/community/py3-mypy-extensions/APKBUILD
@@ -1,28 +1,39 @@
# Contributor: Justin Berthault <justin.berthault@zaclys.net>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer:
pkgname=py3-mypy-extensions
-pkgver=0.4.3
-pkgrel=1
+pkgver=1.0.0
+pkgrel=3
pkgdesc="Experimental type system extensions for mypy typechecker"
-url="http://www.mypy-lang.org/"
+url="https://www.mypy-lang.org/"
arch="noarch"
license="MIT"
depends="python3"
-makedepends="py3-setuptools"
-# tests are not packaged on PyPI so use GitHub
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/python/mypy_extensions/archive/$pkgver.tar.gz"
builddir="$srcdir/"mypy_extensions-$pkgver
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m unittest discover tests
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/*.whl
+ test-env/bin/python3 -m unittest discover tests
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="22d8dc538cf6f77d97f4113dd34fce8095dd98944c7613fab2b3e71a3e9b7df1374654af41ead5c934f789ef1b72f54d980ab06f3ca28b8b4c6bb14ba1ca3ce2 py3-mypy-extensions-0.4.3.tar.gz"
+sha512sums="
+ac89a9f60a2c3df3457d5a6ab7ed47b72dd173646ef57f1450556051617e62046405a69fadeb40d2c24e68ce6ffed56d9182365e3203477facdc935e1a807847 py3-mypy-extensions-1.0.0.tar.gz
+"