aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-mypy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-mypy/APKBUILD')
-rw-r--r--community/py3-mypy/APKBUILD44
1 files changed, 24 insertions, 20 deletions
diff --git a/community/py3-mypy/APKBUILD b/community/py3-mypy/APKBUILD
index b7397763b37..c0de93a5cbb 100644
--- a/community/py3-mypy/APKBUILD
+++ b/community/py3-mypy/APKBUILD
@@ -1,36 +1,40 @@
# Contributor: Justin Berthault <justin.berthault@zaclys.net>
-# Maintainer: Justin Berthault <justin.berthault@zaclys.net>
+# Maintainer: Patrycja Rosa <alpine@ptrcnull.me>
pkgname=py3-mypy
-pkgver=0.902
-pkgrel=0
+pkgver=1.9.0
+pkgrel=1
pkgdesc="Optional static typing for Python (PEP484)"
-options="!check" # Tests fail on builders, pass on CI
-url="https://www.mypy-lang.org/"
-arch="all"
+url="https://mypy-lang.org/"
+arch="noarch"
license="MIT"
-depends="py3-mypy-extensions py3-typing-extensions py3-typed-ast"
-makedepends="python3-dev py3-setuptools"
-checkdepends="py3-pytest py3-pytest-xdist py3-lxml py3-virtualenv"
-source="https://files.pythonhosted.org/packages/source/m/mypy/mypy-$pkgver.tar.gz"
-builddir="$srcdir/"mypy-$pkgver
+depends="
+ py3-mypy-extensions
+ py3-typing-extensions
+ "
+makedepends="python3-dev py3-gpep517 py3-setuptools py3-wheel"
+checkdepends="py3-pytest py3-pytest-xdist py3-lxml py3-typed-ast py3-virtualenv"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/python/mypy/archive/refs/tags/$pkgver.tar.gz"
+builddir="$srcdir/mypy-$pkgver"
+options="!check" # they take forever
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- rm -f \
- mypyc/test/test_analysis.py \
- mypyc/test/test_exceptions.py \
- mypyc/test/test_refcount.py \
- mypyc/test/test_run.py
- py.test-3 -v
+ python3 -m venv --clear --without-pip --system-site-packages test-env
+ test-env/bin/python3 -m installer .dist/mypy-*.whl
+ test-env/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/mypy-*.whl
}
sha512sums="
-4f6aea12ebf009808eabc66964c5111471c34fc2bc68d9cf64ab5feb4e092097ee5572355f585a3149880b16269436f76ddb1a01027082e0451bc1c16e8bf33e mypy-0.902.tar.gz
+aaa975b97e72f00a384a38fee190e39c6469b062a7083c76bb94bb7058ed38f713f65b96bb36a871a430633cab424a0f11e995868f867e2f7a13c4754ed96c89 py3-mypy-1.9.0.tar.gz
"