aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-nashpy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-nashpy/APKBUILD')
-rw-r--r--community/py3-nashpy/APKBUILD32
1 files changed, 19 insertions, 13 deletions
diff --git a/community/py3-nashpy/APKBUILD b/community/py3-nashpy/APKBUILD
index 2cffe36e35f..83d9021bb50 100644
--- a/community/py3-nashpy/APKBUILD
+++ b/community/py3-nashpy/APKBUILD
@@ -2,31 +2,37 @@
# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-nashpy
_pkgorig=nashpy
-pkgver=0.0.32
-pkgrel=0
+pkgver=0.0.41
+pkgrel=1
pkgdesc="A library for the computation of Nash equilibria in two player games"
url="https://github.com/drvinceknight/Nashpy"
-arch="noarch"
+arch="noarch !riscv64" # several errors
license="MIT"
-depends="python3 py3-scipy py3-numpy"
-checkdepends="python3-dev py3-pytest py3-pytest-flake8 py3-pytest-cov py3-hypothesis"
-makedepends="py3-setuptools"
-source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/n/nashpy/nashpy-$pkgver.tar.gz"
-builddir="$srcdir/$_pkgorig-$pkgver"
+depends="python3 py3-deprecated py3-scipy py3-networkx py3-numpy"
+checkdepends="py3-pytest-xdist py3-pytest-benchmark py3-hypothesis"
+makedepends="py3-gpep517 py3-flit-core"
+subpackages="$pkgname-pyc"
+source="https://github.com/drvinceknight/Nashpy/archive/v$pkgver/$_pkgorig-$pkgver.tar.gz"
+builddir="$srcdir/Nashpy-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest src/nashpy --cov=nashpy --cov-fail-under=5 --flake8
+ PYTHONPATH=src \
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/nashpy-$pkgver-py3-none-any.whl
}
-
sha512sums="
-4628aec7495fa32859018bb62c2c2849f221a9a748ea267ebf6cdf850551de5e59546302bc69a01e62f9fdcf1b6a3a61eda36bd8b804e6b5653475d9e0785b35 py3-nashpy-0.0.32.tar.gz
+958c28eace070903be33e295b0025335798aeedb0d05e22484b80b4670990a90425835db6cc6cf008eedb466f4a4c10ae33e242327b8e0f4d49bed7c33ac9941 nashpy-0.0.41.tar.gz
"