aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-networkx/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-networkx/APKBUILD')
-rw-r--r--community/py3-networkx/APKBUILD54
1 files changed, 37 insertions, 17 deletions
diff --git a/community/py3-networkx/APKBUILD b/community/py3-networkx/APKBUILD
index 99d6f81d0e0..3d4b21ee5cb 100644
--- a/community/py3-networkx/APKBUILD
+++ b/community/py3-networkx/APKBUILD
@@ -1,45 +1,65 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
-# Maintainer: Bart Ribbers <bribbers@disroot.org>
+# Maintainer:
pkgname=py3-networkx
-pkgver=2.6.1
+pkgver=3.2.1
pkgrel=0
pkgdesc="Software for complex networks"
-url="https://networkx.github.io/"
-arch="noarch !mips64"
+url="https://networkx.org/"
+arch="noarch"
license="BSD-3-Clause"
depends="
- py3-decorator
- python3
- "
-makedepends="py3-setuptools"
-subpackages="$pkgname-doc"
-checkdepends="
- xdg-utils
- py3-lxml
py3-matplotlib
py3-numpy
py3-pandas
+ py3-scipy
+ "
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+subpackages="$pkgname-doc $pkgname-pyc"
+checkdepends="
+ graphviz
+ py3-lxml
py3-pydot
py3-pygraphviz
py3-pytest
- py3-scipy
+ py3-pytest-xdist
py3-yaml
+ xdg-utils
"
source="https://pypi.python.org/packages/source/n/networkx/networkx-$pkgver.tar.gz"
builddir="$srcdir/networkx-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+
+ # Broken with graphviz
+ # travellingsalesman:
+ # https://github.com/networkx/networkx/issues/5913
+ .testenv/bin/python3 -m pytest -n auto \
+ --ignore networkx/drawing/tests/test_agraph.py \
+ --ignore networkx/algorithms/approximation/tests/test_traveling_salesman.py
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+
+ find "$pkgdir" -type d -name tests -exec rm -r {} \+
+
+ install -Dm644 LICENSE.txt -t "$pkgdir"/usr/share/doc/$pkgname/
+ cp -a examples "$pkgdir"/usr/share/doc/$pkgname/
}
sha512sums="
-132f34eb8790fb366263cfbb501ec5ca0f9c9082562215a06a114b2ec80baf72f5489f27e7fe1cbea49749eab48116e8772ff953339de0caabf37096ce097500 networkx-2.6.1.tar.gz
+579c54a4a016617f5260df01b821c3906c4f289e80ae7bd618c0ebb9e05ebe806e71f1f660e3012531d04572ac4e6670aa73117ed26da8248fbb8ef7228b5803 networkx-3.2.1.tar.gz
"