aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-niaaml/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-niaaml/APKBUILD')
-rw-r--r--community/py3-niaaml/APKBUILD33
1 files changed, 33 insertions, 0 deletions
diff --git a/community/py3-niaaml/APKBUILD b/community/py3-niaaml/APKBUILD
new file mode 100644
index 00000000000..63af0ac6431
--- /dev/null
+++ b/community/py3-niaaml/APKBUILD
@@ -0,0 +1,33 @@
+# Contributor: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
+pkgname=py3-niaaml
+_pkgorig=NiaAML
+pkgver=1.1.7
+pkgrel=0
+pkgdesc="Python automated machine learning framework."
+url="https://github.com/lukapecnik/NiaAML"
+arch="noarch !s390x !riscv64" # py3-scikit-learn, py3-niapy
+license="MIT"
+depends="python3 py3-numpy py3-pandas py3-niapy py3-scikit-learn"
+checkdepends="python3-dev py3-pytest"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/N/NiaAML/NiaAML-$pkgver.tar.gz
+do-not-package-tests.patch"
+builddir="$srcdir/$_pkgorig-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 -m pytest
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="
+a4b1df54746b0d97f3b9a7a1c1a38f860123e77f8cb9eda8a88a64d3afd3512e25467dc686f32d83537175d92d25db1aeb1bdd89a598ac47cbe64dd5f61e6a6c py3-niaaml-1.1.7.tar.gz
+438062e2ee0ab4aae2f8629301bb68cdb95e8ea008cfba54648a31030e702323223f84a51c4932f6894e00a78c01361b150d6014ac279cad2d4badc672c53fb0 do-not-package-tests.patch
+"