aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-niapy/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-niapy/APKBUILD')
-rw-r--r--community/py3-niapy/APKBUILD33
1 files changed, 22 insertions, 11 deletions
diff --git a/community/py3-niapy/APKBUILD b/community/py3-niapy/APKBUILD
index 969e093ea05..c194965db3d 100644
--- a/community/py3-niapy/APKBUILD
+++ b/community/py3-niapy/APKBUILD
@@ -2,30 +2,41 @@
# Maintainer: Iztok Fister, Jr. <iztok@iztok-jr-fister.eu>
pkgname=py3-niapy
_pkgorig=NiaPy
-pkgver=2.0.2
-pkgrel=0
-pkgdesc="Python micro framework for building nature-inspired algorithms."
-url="https://github.com/NiaOrg/NiaPy"
-arch="noarch !riscv64" # py3-matplotlib
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Python micro framework for building nature-inspired algorithms"
+url="https://niapy.org"
+arch="noarch"
license="MIT"
depends="python3 py3-numpy py3-pandas py3-openpyxl py3-matplotlib"
-checkdepends="python3-dev py3-pytest"
-makedepends="py3-setuptools"
+checkdepends="py3-pytest-xdist"
+makedepends="py3-gpep517 py3-poetry-core"
+subpackages="$pkgname-doc $pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/NiaOrg/NiaPy/archive/$pkgver.tar.gz"
builddir="$srcdir/$_pkgorig-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 -m pytest
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
+
+ install -Dm644 CITATION.cff -t "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm644 Algorithms.md -t "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm644 Problems.md -t "$pkgdir"/usr/share/doc/$pkgname
+ install -Dm644 README.md -t "$pkgdir"/usr/share/doc/$pkgname
}
sha512sums="
-d13fe766aa4e1d3150be07845d2fcfa856b6ffd66d70e9a8de187325da3c702f266a1b65ee817879e344d3b6302c12deac8e8f6550699b01c9df900d82be0644 py3-niapy-2.0.2.tar.gz
+d877a0b70ce7bf6208593d08f3f7bd4819a663e3fd3dcae57473ceef1505cf1a881ee82a7e92ebc153d8044df959800110c9915641668c90ebd9bee30fef591e py3-niapy-2.1.0.tar.gz
"