aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-nodeenv/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-nodeenv/APKBUILD')
-rw-r--r--community/py3-nodeenv/APKBUILD24
1 files changed, 16 insertions, 8 deletions
diff --git a/community/py3-nodeenv/APKBUILD b/community/py3-nodeenv/APKBUILD
index 2862287eb53..d684fb6359a 100644
--- a/community/py3-nodeenv/APKBUILD
+++ b/community/py3-nodeenv/APKBUILD
@@ -2,31 +2,39 @@
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-nodeenv
_pkgname=nodeenv
-pkgver=1.6.0
+pkgver=1.8.0
pkgrel=2
pkgdesc="Node.js virtual environment builder"
url="https://ekalinin.github.io/nodeenv/"
arch="all"
license="BSD-3-Clause"
-depends="bash python3"
-makedepends="python3-dev py3-setuptools"
+depends="bash py3-setuptools"
+makedepends="python3-dev py3-gpep517 py3-wheel"
checkdepends="nodejs py3-pytest py3-mock py3-pytest-cov"
+subpackages="$pkgname-pyc"
source="$_pkgname-$pkgver.tar.gz::https://github.com/ekalinin/nodeenv/archive/$pkgver.tar.gz
11-alpine-prebuilt.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- PYTHONPATH="$builddir/src" python3 -m pytest .
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="abf4fe55ba478570a32ff3bb24fc3c60ba2d100822f8295c4c55c301ccdff2dc2d20ef76990ea3ac203e30db8a1e85f3ef2df671f87c0cf7305cf1aeb788efdd nodeenv-1.6.0.tar.gz
-e92b8f702965faeae10263f991d942234fad1b8687e1c1d151860a3a5e5f90b802de4869a3f2995ee915a622167be8fc7df6532f3d106a33538a61cd20b52802 11-alpine-prebuilt.patch"
+sha512sums="
+96dce219e00d3837b2b0083af9fe6d94ed4e3cd029e3da564263ad8656dcb9c52440c2df6a6954095e5cacd03e44437f08695603dea82c28122713045183014f nodeenv-1.8.0.tar.gz
+e92b8f702965faeae10263f991d942234fad1b8687e1c1d151860a3a5e5f90b802de4869a3f2995ee915a622167be8fc7df6532f3d106a33538a61cd20b52802 11-alpine-prebuilt.patch
+"