aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-notify2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-notify2/APKBUILD')
-rw-r--r--community/py3-notify2/APKBUILD8
1 files changed, 5 insertions, 3 deletions
diff --git a/community/py3-notify2/APKBUILD b/community/py3-notify2/APKBUILD
index 891929e162c..bc189fb527d 100644
--- a/community/py3-notify2/APKBUILD
+++ b/community/py3-notify2/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Antoine Fontaine <antoine.fontaine@epfl.ch>
-# Maintainer: Antoine Fontaine <antoine.fontaine@epfl.ch>
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=py3-notify2
pkgver=0.3.1
-pkgrel=1
+pkgrel=7
pkgdesc="Python interface to DBus notifications"
url="https://pypi.org/project/notify2/"
arch="noarch"
@@ -10,9 +10,11 @@ license="BSD-2-Clause"
depends="python3 py3-dbus py3-gobject3"
makedepends="py3-setuptools"
checkdepends="xvfb-run dunst dbus"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/n/notify2/notify2-$pkgver.tar.gz
test-wrapper.sh"
builddir="$srcdir/notify2-$pkgver"
+options="!check" # fail due to some display error
build() {
python3 setup.py build
@@ -24,7 +26,7 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="0b69a64e0a7e4955ee767c975db92c5c60d28c0e54f77498cfb98390771a8f536631fc34e42b5c46c138dfa1054b5516a0809b8e3b0cb9237a39825ddb827109 notify2-0.3.1.tar.gz