aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-numpy/numpy-1.17.0-musl.patch
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-numpy/numpy-1.17.0-musl.patch')
-rw-r--r--community/py3-numpy/numpy-1.17.0-musl.patch16
1 files changed, 11 insertions, 5 deletions
diff --git a/community/py3-numpy/numpy-1.17.0-musl.patch b/community/py3-numpy/numpy-1.17.0-musl.patch
index 3088eefdbe7..5806a56dfbd 100644
--- a/community/py3-numpy/numpy-1.17.0-musl.patch
+++ b/community/py3-numpy/numpy-1.17.0-musl.patch
@@ -1,5 +1,7 @@
Upstream: No
Reason: Enable build on endian musl
+diff --git a/numpy/core/include/numpy/npy_endian.h b/numpy/core/include/numpy/npy_endian.h
+index 5e58a7f..19e5e64 100644
--- a/numpy/core/include/numpy/npy_endian.h
+++ b/numpy/core/include/numpy/npy_endian.h
@@ -12,7 +12,7 @@
@@ -11,9 +13,11 @@ Reason: Enable build on endian musl
#endif
#if defined(BYTE_ORDER) && defined(BIG_ENDIAN) && defined(LITTLE_ENDIAN)
+diff --git a/numpy/core/setup.py b/numpy/core/setup.py
+index 52b51e4..73f3b05 100644
--- a/numpy/core/setup.py
+++ b/numpy/core/setup.py
-@@ -290,7 +290,7 @@ def check_types(config_cmd, ext, build_dir):
+@@ -355,7 +355,7 @@ def check_types(config_cmd, ext, build_dir):
if res:
private_defines.append(('HAVE_ENDIAN_H', 1))
public_defines.append(('NPY_HAVE_ENDIAN_H', 1))
@@ -22,14 +26,16 @@ Reason: Enable build on endian musl
if res:
private_defines.append(('HAVE_SYS_ENDIAN_H', 1))
public_defines.append(('NPY_HAVE_SYS_ENDIAN_H', 1))
+diff --git a/numpy/core/setup_common.py b/numpy/core/setup_common.py
+index ce966dd..2a144fd 100644
--- a/numpy/core/setup_common.py
+++ b/numpy/core/setup_common.py
-@@ -120,7 +120,7 @@ OPTIONAL_HEADERS = [
+@@ -140,7 +140,7 @@ OPTIONAL_HEADERS = [
"emmintrin.h", # SSE2
"immintrin.h", # AVX
"features.h", # for glibc version linux
- "xlocale.h", # see GH#8367
+ "locale.h", # see GH#8367
- "dlfcn.h", # dladdr
- "sys/mman.h", #madvise
- ]
+ "dlfcn.h", # dladdr
+ "execinfo.h", # backtrace
+ "libunwind.h", # backtrace for LLVM/Clang using libunwind