aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-oauth2/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-oauth2/APKBUILD')
-rw-r--r--community/py3-oauth2/APKBUILD46
1 files changed, 33 insertions, 13 deletions
diff --git a/community/py3-oauth2/APKBUILD b/community/py3-oauth2/APKBUILD
index 09e47f50f95..df3e04f8cd5 100644
--- a/community/py3-oauth2/APKBUILD
+++ b/community/py3-oauth2/APKBUILD
@@ -1,35 +1,55 @@
# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
-# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
+# Contributor: fossdd <fossdd@pwned.life>
+# Maintainer: fossdd <fossdd@pwned.life>
pkgname=py3-oauth2
_pkgname=oauth2
pkgver=1.9.0
-pkgrel=3
+pkgrel=11
pkgdesc="Python3 library for OAuth"
-url="https://github.com/simplegeo/python-oauth2"
+url="https://github.com/joestump/python-oauth2"
arch="noarch"
license="MIT"
-depends="python3 py3-httplib2"
-makedepends="py3-setuptools"
-checkdepends="py3-mock py3-coverage"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.post1.tar.gz"
+depends="py3-httplib2"
+makedepends="
+ py3-setuptools
+ py3-gpep517
+ py3-wheel
+ "
+checkdepends="
+ py3-mock
+ py3-pytest
+ "
+subpackages="$pkgname-pyc"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.post1.tar.gz
+ assertEquals.patch
+ "
builddir="$srcdir"/$_pkgname-$pkgver.post1
-replaces="py-oauth2" # Bakcwards compatibility
-provides="py-oauth2=$pkgver-r$pkgrel" # Bakcwards compatibility
+replaces="py-oauth2" # Backwards compatibility
+provides="py-oauth2=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer "$builddir"/.dist/*.whl
+ .testenv/bin/python3 -m pytest -v
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
# Tests don't need to be installed
rm -rf "$pkgdir"/usr/lib/python3*/site-packages/tests/
}
-sha512sums="a3b64eef331d4c4f59c275f14efb2dfb48ad60de47a59a88106f60d64428a09b76d8bedf08c98c113493968d83708b1478b4b61b2b5528b5b01fa22777daff4c oauth2-1.9.0.post1.tar.gz"
+sha512sums="
+a3b64eef331d4c4f59c275f14efb2dfb48ad60de47a59a88106f60d64428a09b76d8bedf08c98c113493968d83708b1478b4b61b2b5528b5b01fa22777daff4c oauth2-1.9.0.post1.tar.gz
+b82de89633a0cb4e528642ad8162666e777b267cad3bccbf04c3e9e08bcd1d8c57cf28214eeef45c683b0ec6c51bb34c091bf7b6626db90f522e744b151bfaf9 assertEquals.patch
+"