aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-oauth2
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-oauth2')
-rw-r--r--community/py3-oauth2/APKBUILD34
1 files changed, 34 insertions, 0 deletions
diff --git a/community/py3-oauth2/APKBUILD b/community/py3-oauth2/APKBUILD
new file mode 100644
index 00000000000..bb3929a0264
--- /dev/null
+++ b/community/py3-oauth2/APKBUILD
@@ -0,0 +1,34 @@
+# Contributor: Peter Bui <pnutzh4x0r@gmail.com>
+# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
+pkgname=py3-oauth2
+_pkgname=oauth2
+pkgver=1.9.0
+pkgrel=2
+pkgdesc="Python3 library for OAuth"
+url="https://github.com/simplegeo/python-oauth2"
+arch="noarch"
+license="MIT"
+depends="python3 py3-httplib2"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.post1.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver.post1
+
+replaces="py-oauth2" # Bakcwards compatibility
+provides="py-oauth2=$pkgver-r$pkgrel" # Bakcwards compatibility
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ # Tests don't need to be installed
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/tests/
+}
+
+sha512sums="a3b64eef331d4c4f59c275f14efb2dfb48ad60de47a59a88106f60d64428a09b76d8bedf08c98c113493968d83708b1478b4b61b2b5528b5b01fa22777daff4c oauth2-1.9.0.post1.tar.gz"