aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-oauthlib/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-oauthlib/APKBUILD')
-rw-r--r--community/py3-oauthlib/APKBUILD15
1 files changed, 9 insertions, 6 deletions
diff --git a/community/py3-oauthlib/APKBUILD b/community/py3-oauthlib/APKBUILD
index 2a0e9d04b31..522468a1771 100644
--- a/community/py3-oauthlib/APKBUILD
+++ b/community/py3-oauthlib/APKBUILD
@@ -1,17 +1,18 @@
# Contributor: Eivind Uggedal <eu@eju.no>
-# Maintainer:
+# Maintainer: Steven Guikal <void@fluix.one>
pkgname=py3-oauthlib
_pkgname=oauthlib
-pkgver=2.1.0
-pkgrel=5
+pkgver=3.2.2
+pkgrel=3
pkgdesc="Python3 implementation of the OAuth request-signing logic"
options="!check" # requires 'blinker' that is in testing/
-url="https://github.com/idan/oauthlib"
+url="https://github.com/oauthlib/oauthlib"
arch="noarch"
license="BSD-3-Clause"
depends="python3"
makedepends="py3-setuptools"
checkdepends="py3-nose py3-cryptography py3-jwt" # py3-blinker"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/o/oauthlib/oauthlib-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -27,7 +28,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="bd749c7b65de00cc0c371053577623aca5767a0b20e41b2d5e3e20f8246e84bf360472b4ec983023227d6164ecd7ed4647c41cd8f425fe21200a2c25a9049ffd oauthlib-2.1.0.tar.gz"
+sha512sums="
+c147b96e0ab0d1a8845f525e80831cfd04495134dd1f17fd95eac62f3a95c91e6dca9d38e34206537d77f3c12dd5b553252239318ba39546979c350e96536b8b oauthlib-3.2.2.tar.gz
+"