aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-oletools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-oletools/APKBUILD')
-rw-r--r--community/py3-oletools/APKBUILD13
1 files changed, 7 insertions, 6 deletions
diff --git a/community/py3-oletools/APKBUILD b/community/py3-oletools/APKBUILD
index d9f3f3f8f74..dc626357a81 100644
--- a/community/py3-oletools/APKBUILD
+++ b/community/py3-oletools/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Duncan Bellamy <dunk@denkimushi.com>
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
pkgname=py3-oletools
-pkgver=0.60
-pkgrel=0
+pkgver=0.60.1
+pkgrel=3
pkgdesc="tools to analyze security characteristics of MS Office and OLE files"
url="https://www.decalage.info/python/oletools"
arch="noarch"
@@ -21,6 +21,7 @@ depends="python3
# tablestream and xglob have no upstream repo or page on declage.com
makedepends="py3-setuptools"
checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
source="$pkgname-$pkgver.tar.gz::https://github.com/decalage2/oletools/archive/refs/tags/v$pkgver.tar.gz
unbundle.patch
"
@@ -31,15 +32,15 @@ build() {
}
check() {
- # deselected test returns unknown file type
- pytest --deselect tests/oleid/test_basic.py::TestOleIDBasic::test_all
+ # deselected test returns unknown file type, test_xlm returns 2 instead of 3 macros
+ pytest --deselect tests/oleid/test_basic.py::TestOleIDBasic::test_all --deselect tests/olevba/test_basic.py::TestOlevbaBasic::test_xlm
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
sha512sums="
-2e29bd29e013812a9c9fdfed237232d499632692861caadb1281fd71e6f8d59a4270a5c82aab119c77cb058aec8c08c54c96c177bb77464c63704869b29bd06f py3-oletools-0.60.tar.gz
+c867c8f1c3d2b8217ae54ba13ae5566ccca173a8824e2d3ea83d22dad0d3b30508135a677e77838318ee1a1950fd1d477968806c0fb9e8302c4a23d4665e02fb py3-oletools-0.60.1.tar.gz
a7f015fac09f36fffb971818519d7d0d87884eb80580c068f5e7460427fc713272a3a4ed78d321f65d8ad47e61966e4a9db52b50736bace3f80f44df17ec8de2 unbundle.patch
"