aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-oletools/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-oletools/APKBUILD')
-rw-r--r--community/py3-oletools/APKBUILD46
1 files changed, 46 insertions, 0 deletions
diff --git a/community/py3-oletools/APKBUILD b/community/py3-oletools/APKBUILD
new file mode 100644
index 00000000000..dc626357a81
--- /dev/null
+++ b/community/py3-oletools/APKBUILD
@@ -0,0 +1,46 @@
+# Contributor: Duncan Bellamy <dunk@denkimushi.com>
+# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
+pkgname=py3-oletools
+pkgver=0.60.1
+pkgrel=3
+pkgdesc="tools to analyze security characteristics of MS Office and OLE files"
+url="https://www.decalage.info/python/oletools"
+arch="noarch"
+license="BSD-2-Clause AND MIT"
+depends="python3
+ py3-colorclass
+ py3-easygui
+ py3-msoffcrypto-tool
+ py3-olefile
+ py3-parsing
+ py3-pcodedmp
+ py3-prettytable
+ py3-xxxswf
+ "
+# bundled dependency oledump has no setup.py
+# tablestream and xglob have no upstream repo or page on declage.com
+makedepends="py3-setuptools"
+checkdepends="py3-pytest"
+subpackages="$pkgname-pyc"
+source="$pkgname-$pkgver.tar.gz::https://github.com/decalage2/oletools/archive/refs/tags/v$pkgver.tar.gz
+ unbundle.patch
+ "
+builddir="$srcdir/oletools-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ # deselected test returns unknown file type, test_xlm returns 2 instead of 3 macros
+ pytest --deselect tests/oleid/test_basic.py::TestOleIDBasic::test_all --deselect tests/olevba/test_basic.py::TestOlevbaBasic::test_xlm
+}
+
+package() {
+ python3 setup.py install --skip-build --root="$pkgdir"
+}
+
+sha512sums="
+c867c8f1c3d2b8217ae54ba13ae5566ccca173a8824e2d3ea83d22dad0d3b30508135a677e77838318ee1a1950fd1d477968806c0fb9e8302c4a23d4665e02fb py3-oletools-0.60.1.tar.gz
+a7f015fac09f36fffb971818519d7d0d87884eb80580c068f5e7460427fc713272a3a4ed78d321f65d8ad47e61966e4a9db52b50736bace3f80f44df17ec8de2 unbundle.patch
+"