aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-opencl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-opencl/APKBUILD')
-rw-r--r--community/py3-opencl/APKBUILD33
1 files changed, 24 insertions, 9 deletions
diff --git a/community/py3-opencl/APKBUILD b/community/py3-opencl/APKBUILD
index 1c6c15a8607..e6b4679d240 100644
--- a/community/py3-opencl/APKBUILD
+++ b/community/py3-opencl/APKBUILD
@@ -2,16 +2,26 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=py3-opencl
_pkgreal=pyopencl
-pkgver=2021.2.6
+pkgver=2024.1
pkgrel=1
pkgdesc="Python3 wrapper for OpenCL"
-url="https://pypi.python.org/pypi/pyopencl"
+url="https://pypi.org/project/pyopencl"
arch="all"
license="MIT"
-depends="py3-appdirs py3-decorator py3-numpy py3-six py3-mako py3-pytools"
-makedepends="python3-dev py3-setuptools ctags libffi-dev mesa-dev opencl-headers
- opencl-icd-loader-dev py3-cparser py3-cffi py3-pybind11-dev py3-numpy-dev"
+depends="py3-platformdirs py3-numpy py3-mako py3-pytools"
+makedepends="
+ libffi-dev
+ mesa-dev
+ opencl-dev
+ py3-gpep517
+ py3-numpy-dev
+ py3-pybind11-dev
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
checkdepends="py3-pytest py3-py"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
options="!check" # tests require python-theano which isn't packed yet
@@ -20,17 +30,22 @@ replaces="py-opencl" # Backwards compatibility
provides="py-opencl=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
sha512sums="
-b7bea4903a34104c538545c611554c1651ae7a94ee56d8c7129a88a9e547911fac085617b4238fac33534c9b981bcfdb9fabd716456a86fa428cfd42d9cb128c pyopencl-2021.2.6.tar.gz
+abf27d67f8c3633c71e662938a919c88a34b0b66cc3c213644f92a8733aed3c9b7593542dd9b45a080941976dadeb4f49a23a986482110824b554e3a0d317176 pyopencl-2024.1.tar.gz
"