aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-opencl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-opencl/APKBUILD')
-rw-r--r--community/py3-opencl/APKBUILD38
1 files changed, 27 insertions, 11 deletions
diff --git a/community/py3-opencl/APKBUILD b/community/py3-opencl/APKBUILD
index ce09296cf87..e6b4679d240 100644
--- a/community/py3-opencl/APKBUILD
+++ b/community/py3-opencl/APKBUILD
@@ -2,17 +2,26 @@
# Maintainer: Stuart Cardall <developer@it-offshore.co.uk>
pkgname=py3-opencl
_pkgreal=pyopencl
-pkgver=2019.1.2
+pkgver=2024.1
pkgrel=1
pkgdesc="Python3 wrapper for OpenCL"
-url="https://pypi.python.org/pypi/pyopencl"
-# mips blocked due to py3-numpy
-arch="all !mips !mips64"
+url="https://pypi.org/project/pyopencl"
+arch="all"
license="MIT"
-depends="py3-appdirs py3-decorator py3-numpy py3-six py3-mako py3-pytools"
-makedepends="python3-dev py3-setuptools ctags libffi-dev mesa-dev opencl-headers
- opencl-icd-loader-dev py3-cparser py3-cffi py3-pybind11-dev py3-numpy-dev"
+depends="py3-platformdirs py3-numpy py3-mako py3-pytools"
+makedepends="
+ libffi-dev
+ mesa-dev
+ opencl-dev
+ py3-gpep517
+ py3-numpy-dev
+ py3-pybind11-dev
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
checkdepends="py3-pytest py3-py"
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgreal:0:1}/$_pkgreal/$_pkgreal-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
options="!check" # tests require python-theano which isn't packed yet
@@ -21,15 +30,22 @@ replaces="py-opencl" # Backwards compatibility
provides="py-opencl=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="b2850622253f480cafacadbb9d13afea801af9d4dd52679f132fc0e5f1d4c2f4d3bdf83c9ed64c14c19ead75e6d36afa8b57ff52bbea135fc02291b1fe7b8636 pyopencl-2019.1.2.tar.gz"
+sha512sums="
+abf27d67f8c3633c71e662938a919c88a34b0b66cc3c213644f92a8733aed3c9b7593542dd9b45a080941976dadeb4f49a23a986482110824b554e3a0d317176 pyopencl-2024.1.tar.gz
+"