aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-openssl/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-openssl/APKBUILD')
-rw-r--r--community/py3-openssl/APKBUILD33
1 files changed, 24 insertions, 9 deletions
diff --git a/community/py3-openssl/APKBUILD b/community/py3-openssl/APKBUILD
index a1808e63a85..be4559b6d05 100644
--- a/community/py3-openssl/APKBUILD
+++ b/community/py3-openssl/APKBUILD
@@ -1,32 +1,47 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=py3-openssl
_pkgname=pyOpenSSL
-pkgver=20.0.1
+pkgver=24.1.0
pkgrel=1
pkgdesc="Python3 wrapper module around the OpenSSL library"
url="https://github.com/pyca/pyopenssl"
arch="noarch"
license="Apache-2.0"
-depends="python3 py3-cryptography py3-six"
-makedepends="py3-setuptools"
-checkdepends="py3-pytest"
+depends="python3 py3-cryptography"
+makedepends="
+ py3-gpep517
+ py3-setuptools
+ py3-wheel
+ "
+checkdepends="
+ py3-pretend
+ py3-pytest-rerunfailures
+ py3-pytest-xdist
+ "
+subpackages="$pkgname-pyc"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
-options="!check" # depends on flaky
replaces="py-openssl" # Backwards compatibility
provides="py-openssl=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
- python3 setup.py test
+ python3 -m venv --clear --without-pip --system-site-packages .testenv
+ .testenv/bin/python3 -m installer .dist/*.whl
+ .testenv/bin/python3 -m pytest -n auto
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/*.whl
}
-sha512sums="e81e0870398b882d77453b02e972559c0be82dbfe87bd8a48a65e8943acc3ea07dc8c3150b88e299c237496043443d1a5832219c337e4436f99ef419b36dd23f pyOpenSSL-20.0.1.tar.gz"
+sha512sums="
+acb07025f085d2fe9338e5ce5f65937001b1a8376c41ac532e9b0548668ce05c844e3e28c58efad812a034becf8e24aa9504165ff6af4c3b085cf463fa4d2fb6 pyOpenSSL-24.1.0.tar.gz
+"