aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-paho-mqtt/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-paho-mqtt/APKBUILD')
-rw-r--r--community/py3-paho-mqtt/APKBUILD13
1 files changed, 8 insertions, 5 deletions
diff --git a/community/py3-paho-mqtt/APKBUILD b/community/py3-paho-mqtt/APKBUILD
index 248aac78e2b..3d954934afd 100644
--- a/community/py3-paho-mqtt/APKBUILD
+++ b/community/py3-paho-mqtt/APKBUILD
@@ -1,15 +1,16 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-paho-mqtt
-pkgver=1.5.1
-pkgrel=1
+pkgver=1.6.1
+pkgrel=2
pkgdesc="Python3 MQTT version 3.1/3.1.1 client class"
url="https://www.eclipse.org/paho/"
arch="noarch"
license="EPL-1.0"
depends="python3"
makedepends="py3-setuptools"
-checkdepends="py3-pytest"
+checkdepends="py3-pytest py3-six"
+subpackages="$pkgname-pyc"
source="paho-mqtt-$pkgver.tar.gz::https://github.com/eclipse/paho.mqtt.python/archive/v$pkgver.tar.gz"
builddir="$srcdir"/paho.mqtt.python-$pkgver
@@ -31,7 +32,9 @@ check() {
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 setup.py install --skip-build --root="$pkgdir"
}
-sha512sums="7e686bcc702f70c45ab061aa9833d42c4356d5002d27a035a685ca384a5b7d5e9dfd88ac95183816e08dd131463582707acd1d2e0f6de0f7dbbb6a6d0a615c97 paho-mqtt-1.5.1.tar.gz"
+sha512sums="
+8a13c1f6f97138728d5cab6f7bcd6474942fdf9dfc18d1fad723d50de81f4e062953b5bef2ebbde27b08e480eed305ecbfeae467d70eb10f07ec0adca11750ec paho-mqtt-1.6.1.tar.gz
+"