aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-pandas/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-pandas/APKBUILD')
-rw-r--r--community/py3-pandas/APKBUILD42
1 files changed, 33 insertions, 9 deletions
diff --git a/community/py3-pandas/APKBUILD b/community/py3-pandas/APKBUILD
index 7ad80d96e92..76ccad8d306 100644
--- a/community/py3-pandas/APKBUILD
+++ b/community/py3-pandas/APKBUILD
@@ -2,27 +2,51 @@
# Maintainer: Carlos Giraldo <cgiraldo@gradiant.org>
pkgname=py3-pandas
_pkgname=pandas
-pkgver=1.2.1
-pkgrel=0
+pkgver=2.0.3
+pkgrel=1
pkgdesc="Powerful data structures for data analysis, time series, and statistics"
url="https://pandas.pydata.org/"
-arch="all !mips !mips64" # blocked by py3-numpy
+arch="all"
license="BSD-3-Clause"
-depends="py3-dateutil py3-numpy py3-tz"
-makedepends="linux-headers py3-numpy-dev python3-dev py3-setuptools cython"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
+depends="
+ py3-dateutil
+ py3-numpy
+ py3-tz
"
+makedepends="
+ cython
+ linux-headers
+ py3-gpep517
+ py3-numpy-dev
+ py3-python-versioneer
+ py3-setuptools
+ py3-wheel
+ python3-dev
+ "
+subpackages="$pkgname-pyc $pkgname-tests::noarch"
+source="https://github.com/pandas-dev/pandas/releases/download/v$pkgver/pandas-$pkgver.tar.gz"
builddir="$srcdir/$_pkgname-$pkgver"
+options="!check" # todo
replaces="py-pandas" # Backwards compatibility
provides="py-pandas=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- python3 setup.py build
+ export CFLAGS="$CFLAGS -flto=auto -O3"
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
package() {
- python3 setup.py install --prefix=/usr --root="$pkgdir"
+ python3 -m installer -d "$pkgdir" \
+ .dist/pandas-$pkgver-*.whl
+}
+
+tests() {
+ amove usr/lib/python*/site-packages/pandas/tests
}
-sha512sums="9bf9212ebdd07785f1877f5f80d6a5beb4637e8a1cf741e32a705a48724280a8e8daae209c66c1a3f00718b566127d77af578d6c72a5d9b68e2b03784c604083 pandas-1.2.1.tar.gz"
+sha512sums="
+bee3640521692545cb063b78c85f5ab90817c8029156f97856af4c9edfcc3e13596b48c4c1b4060c92e7e75b3b876d0734f7c1e3b2096d44c52ec09372c99d2e pandas-2.0.3.tar.gz
+"