aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-parametrize-from-file/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-parametrize-from-file/APKBUILD')
-rw-r--r--community/py3-parametrize-from-file/APKBUILD22
1 files changed, 11 insertions, 11 deletions
diff --git a/community/py3-parametrize-from-file/APKBUILD b/community/py3-parametrize-from-file/APKBUILD
index 42160fce6f3..2c46f5f77a4 100644
--- a/community/py3-parametrize-from-file/APKBUILD
+++ b/community/py3-parametrize-from-file/APKBUILD
@@ -1,27 +1,24 @@
# Contributor: Andy Hawkins <andy@gently.org.uk>
# Maintainer: Andy Hawkins <andy@gently.org.uk>
pkgname=py3-parametrize-from-file
-pkgver=0.14.0
-pkgrel=0
+pkgver=0.20.0
+pkgrel=1
pkgdesc="Parametrize From File"
url="https://parametrize-from-file.readthedocs.io/en/latest/"
arch="noarch"
license="MIT"
depends="
- python3>=3.6
+ python3>=3.8
py3-toml
py3-yaml
py3-nestedtext
py3-tidyexc
py3-more-itertools>=8.10
- py3-contextlib2
py3-decopatch
- py3-voluptuous
"
makedepends="
- py3-build
- py3-flit
- py3-installer
+ py3-flit-core
+ py3-gpep517
"
checkdepends="
py3-pytest
@@ -29,11 +26,14 @@ checkdepends="
py3-coveralls
py3-numpy
"
+subpackages="$pkgname-pyc"
source="https://github.com/kalekundert/parametrize_from_file/archive/v$pkgver/parametrize_from_file-v$pkgver.tar.gz"
builddir="$srcdir/parametrize_from_file-$pkgver"
build() {
- python3 -m build --no-isolation --wheel .
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
}
check() {
@@ -42,9 +42,9 @@ check() {
package() {
python3 -m installer -d "$pkgdir" \
- dist/parametrize_from_file-$pkgver-py2.py3-none-any.whl
+ .dist/parametrize_from_file*.whl
}
sha512sums="
-b1e061229139a11a11a88aec19c6051d9306cc3106ee1b1a49d905229de481313d2a73dc0be2d12027ba4870cf7877a05dd0fc4d836baf7be48c94a40ef977dd parametrize_from_file-v0.14.0.tar.gz
+b6911d2f2429b97f5a6a2ae81695a900aa27b9287ea07e0cfb9b791c2d36c42d44f01ee65f0a7c4517ac749d7ad2b0ad8c51b065be68d0d9bc570104bde9d205 parametrize_from_file-v0.20.0.tar.gz
"