aboutsummaryrefslogtreecommitdiffstats
path: root/community/py3-parametrize-from-file/APKBUILD
diff options
context:
space:
mode:
Diffstat (limited to 'community/py3-parametrize-from-file/APKBUILD')
-rw-r--r--community/py3-parametrize-from-file/APKBUILD50
1 files changed, 50 insertions, 0 deletions
diff --git a/community/py3-parametrize-from-file/APKBUILD b/community/py3-parametrize-from-file/APKBUILD
new file mode 100644
index 00000000000..9b0342b7f02
--- /dev/null
+++ b/community/py3-parametrize-from-file/APKBUILD
@@ -0,0 +1,50 @@
+# Contributor: Andy Hawkins <andy@gently.org.uk>
+# Maintainer: Andy Hawkins <andy@gently.org.uk>
+pkgname=py3-parametrize-from-file
+pkgver=0.19.0
+pkgrel=1
+pkgdesc="Parametrize From File"
+url="https://parametrize-from-file.readthedocs.io/en/latest/"
+arch="noarch"
+license="MIT"
+depends="
+ python3>=3.6
+ py3-toml
+ py3-yaml
+ py3-nestedtext
+ py3-tidyexc
+ py3-more-itertools>=8.10
+ py3-decopatch
+ "
+makedepends="
+ py3-flit-core
+ py3-gpep517
+ "
+checkdepends="
+ py3-pytest
+ py3-pytest-cov
+ py3-coveralls
+ py3-numpy
+ "
+subpackages="$pkgname-pyc"
+source="https://github.com/kalekundert/parametrize_from_file/archive/v$pkgver/parametrize_from_file-v$pkgver.tar.gz"
+builddir="$srcdir/parametrize_from_file-$pkgver"
+
+build() {
+ gpep517 build-wheel \
+ --wheel-dir .dist \
+ --output-fd 3 3>&1 >&2
+}
+
+check() {
+ PYTHONPATH="$PWD/build/lib" pytest
+}
+
+package() {
+ python3 -m installer -d "$pkgdir" \
+ .dist/parametrize_from_file*.whl
+}
+
+sha512sums="
+0fd468aa19cf9a9cc9be17893ad75d31facf7d8d43227aac2e007c17daf4fcb2c239a3493ddc025c8c639dbba2fe5fc351117755ea1b7173435172c9d3f1f910 parametrize_from_file-v0.19.0.tar.gz
+"